Discussions

Ask a Question

Connecting to dbForge Studio

Trying to connect dbForge Studio but having trouble with SSL settings. Any idea on how to do this? Wish I could share a screen shot???

Row limit for indiviual Service Accounts

Hi, I have a connected Postgresql database and I want to limit access to certain read-only individuals. For example, I want to limit the read-only Service Accounts to only query up to 1,000 rows per database, per day. Is this possible under Bit.IOs current platform? If not, is there a service I can connect my BitIO Postgresql database that can help manage the limits for each Service Account? Thank you

I work on SQL Snow Day Module 4, Creating and Updating Tables,the result is : Permision Denied!

I would like to know the reasons of this output. Sincerly

New table not showing up (bug report)

Several times, after creating a new table, the new table doesn't show up in the user interface, left-side menu. I ran CREATE TABLE vendor_report AS SELECT .... The table, I believe was created. But it doesn't show up in the left-side "Tables" menu. Strangely, once I run this command ... CREATE TABLE Persons ( PersonID int, LastName varchar(255), FirstName varchar(255), Address varchar(255), City varchar(255) ); ... the tables show up: both vendor_report and Persons. Weird, this has happened several times over several days now.

Unable to Parse URL: IntelliJ

when trying to connect to a database through IntelliJ, I get this error: [99999] Unable to parse URL jdbc:postgresql://db.bit.io:5432/bongo/bnogodb. I have tried turning on single database mode but that just throws: Unable to reconfigure connection to the database bongo/bnogodb.

Branching on the roadmap?

Do you have any plans to add support for branching? E.g. how PlanetScale added for MySQL. Thanks!

DataGrip fails to introspect [99999] Unable to parse URL.

DataGrip connects to Bit.io database properly but cannot introspect the database saying `[99999] Unable to parse URL.`. Also not available to run any queries from query console.

Hi airbyte connection with api not working

Hi I tried a integration with airbyte , in the normalization part is always failing, I guess the problem is related with the permission in the user. I tried with a custom api source and with the poke api in airbyte and in both failed.

feature request: IP address whitelist

The endpoints are currently exposed to the internet. However, as this is undesirable from a security point of view, we would like the ability to block access from sources other than the authorised connection source. I would appreciate your consideration.

Different kinds of public databases/schemas

I can't quite figure out what the differences are in the following kinds of public databases, are there different kinds of public databases? How do I select the schema to upload my data onto as shown in [this](https://docs.bit.io/docs#upload-your-first-data-file) the tutorial? ## [Public Database 1](https://bit.io/bitdotio/census-surnames) - In contrast to the Public Database 2 below, each of the tables is listed under the `public` schema. - How do I reference the tables here from the query editor of my personal test database? ## [Public Database 2](https://bit.io/alanparadise/nw) - Seems like this kind of public database has another nested schema in the database. - Top left shows `alanparadise/nw` as the database, but in the list of tables on the left sidebar, all of them are listed under `alanparadise/nw` again. - Does this mean reference to the `orders` table would be `"alanparadise/nw"."alanparadise/nw"."orders"` when I'm trying referencing from the query editor of my personal test database? Thanks,